MP10w Sleepy Sleepy Time

I had a set of VorTech MP10w pumps in my tank for a while with no issues (Gen v1 way before QD). Finally, the day came and one of them stopped working… dang.

I put my hand on the dry side and I felt nothing. The driver was still lit up and looked like it was working fine, just to make sure I swapped the wet sides of the two MP10w to see if it was the issue and nope, I figured I was not that lucky. Just to eliminate options I swapped the two dry sides to see if there was a problem with the driver, both drivers seem to be working fine. I moved it back it was clear to me that the dry side of the wave maker had seen better days and was a goner.

I jumped on EcoTech’s website and there was only one option to choose from for the dry side so I ordered it. I felt like that was really easy… a little too easy you might say.

The new part came in a few days later and I quickly install proceeded to install it. We were about to sit down for dinner, I told my wife this will just take me 2 min max to swap out, you know the famous last words that will make sure that the project is jinxed. As I stated I had it swapped out in just a min or two max but this time when I turned it on the driver was giving an error message, so that meant it was time to Google why my driver was upset with me. The error message claimed that the wet side was locked. I was fairly sure this was not the case how I swapped them before but who knows so I swapped the two wet sides and tried again and sure enough I got the same error. 

I figure I must have damaged the driver is some way that could be the only logical thing... right! So I start to swap the two wet sides on my two MP10w pumps (again) and as I started to unplug the new drive side I noticed something looked strange. I garbed the old one and it looked at it and sure enough. The old one had 8 wires connecting to the driver board and the new one only had 4. Dang, it I must have ordered the wrong one…

I jump back on the EcoTech website and sure enough, it was the only option online so I contact EcoTech support, figured maybe I had to force a new firmware onto it or something to make it work and sure enough they dry side is only made for the QD model and they don’t make my model anymore.  But no worries I just have to buy the QD driver upgrade and the new dry side will work. At this point, I am too far down the rabbit hole to turn back so I order the new QD driver upgrade.


A few days later the new driver comes in, replacing it is super easy, even though I did not have plans to say that it was going to be easy out loud. This time I kept my trap shut and just went on to replacing it. Needless to say, it was a very simple process. 

I took out the 3 screws from the back side of the original driver.


I then unplug the dry side plug from the little circuit board (this is possibly the hardest part of the entire process, yes I know that is the new board not the old one, I forgot to take a picture of it).


How my original wave maker was the MP10w and I was doing the QD upgrade the new driver did not have the wireless module. I had to remove the wireless module from the old driver and place it on the new QD driver. This process is super simple, you just pull the module away from the board and then line up the pins and push the module into the same location on the new QD driver.